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U ovom tutorijalu, naučićete kako da kreirate osnovni veb sajt koristeći Dreamweaver CS4. Pre 
toga treba dobro osmisliti izgled svog sajta i pripremiti ga koristeći neki editor za slike (Adobe 
Fireworks, Adobe Photoshop, Corel PhotoPaint...). Slike koje koristimo obično treba da kopiramo 
u jedan ili nekoliko poddirektorijuma našeg veb sajta (na primer layout ili images). Tek kada 
imamo potreban dizajn, onda možemo da počnemo da radimo na izradi sajta. 
 

Kreiranje novog sajta 

 

Prvi korak je da kreiramo direktorijum na računaru u kome ćemo čuvati fajlove našeg veb sajta, 
što će nam biti ponuđeno kada pokrenemo Dreamweaver. U dijalogu je potrebno upisati ime 
sajta koji ćemo kreirati i URL adresu, ukoliko ćemo odmah postaviti sajt preko nekog FTP 
klijenta. Kliknuti na Next. 
 

 
 

Drugi dijalog koji će se pojaviti nudi korisniku mogućnost korišćenja serverskih tehnologija 
(ColdFusion, ASP.NET, ASP, JSP ili PHP) u izradi veb sajta. Mi nećemo izabrati takve tehnologije, 
jer nam za sada nije potreban rad sa bazom podataka, već ćemo praviti veb sajt baziran na 
tehnologijama HTML, CSS i JavaScript. Nakon toga, kliknuti na Next. 
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U trećem dijalogu potrebno je upisati direktorijum gde će biti sačuvan projekat, potom kliknuti 
na Next, a u četvrtom dijalogu način povezivanja sa serverom (u ovom slučaju nećemo 
pokazivati). 
 

 
 

Nakon pregleda svih informacija koje ste uneli, kliknuti na Done. 
 
 
 
 
Ako se već nalazimo u Dreamweaver-u, odabrati u Create New sekciji 
Dreamweaver Site... 
 
 

Kreiraćemo sada jednu stranicu primer.html, izborom 
opcije Create New => HTML. Sa desne strane pojaviće 
nam se Files Panel, struktura fajlova i 
poddirektorijuma (stablo) u direktorijumu našeg 
novog sajta. Novi direktorijum možemo kreirati 
desnim klikom na površinu panela, pa New Folder 
(kreiramo direktorijum images). Na 
isti način možemo dodati i novu 
HTML stranicu (opcija New File). 
 
Ako se paneli ne vide, kliknuti na 
duplu strelicu - Expand Panels. 
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Opcije i prikazivanja u Dreamweaver-u 

Podrazumevani prikaz u Dreamweaver-u (Split dugme) prikazuje u gornjem prozoru HTML kod 

koji kucate (označen brojem #1 na slici) i izgled određene stranice u donjem prozoru (označen 

brojem #2 na slici). Način prikazivanja je moguće promeniti samo na prozor sa kodom (Code 

dugme) ili samo na prozor sa dizajnom (Design dugme). Korisnik može da kreira stranicu i 

unošenjem koda i direktnom promenom u dizajnu stranice. Ispod ova dva prozora nalazi se 

Properties panel, koji za svaki HTML ili CSS element daje detaljne informacije. U primeru koji je 

dat, nalazimo se na elementu <a href=...> za link na drugu stranicu, što je prikazano u polju Link. 

Možemo promeniti polje Target, gde ćemo iz padajuće liste na primer odabrati opciju _blank, 

koja novu stranicu otvara u novom prozoru, pa će se naša stranica Elektrotehničkog fakulteta 

podrazumevano otvarati u novom prozoru. 

 
U ovom Properties panelu, kada menjamo HTML kod stranice, pojaviće se dugme za 

osvežavanje stranice (kao što je prikazano na slici), jer se dizajn neće automatski menjati, sve 

dok korisnik to ne želi. 
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U File meniju, postoji opcija Preview in Browser, gde korisnik može da odabere jedan od 

ponuđenih veb pregledača i vidi kako trenutna stranica/sajt izgleda u tom veb pregledaču. 

Opcijom Edit Browser List moguće je dopuniti tu listu sa drugim instaliranim veb pregledačima. 

U praksi je najbolje, da kada pravimo sajt, taj sajt testiramo u svim veb pregledačima koje 

koriste budući korisnici tog sajta. Danas se najviše koriste (Mozilla Firefox, Google Chrome, 

Internet Explorer, Opera, Safari, i drugi). 

Opcijom File => New, moguće je kreirati novu stranicu ili novi šablon (eng. template), što će biti 

pokazano u sledećem poglavlju. U File meniju, moguće su još i standardne opcije za rad sa 

fajlovima: otvaranje nove stranice, otvaranje najskorije korišćenih stranica, snimanje stranica i 

štampanje koda. 

U Edit meniju, postoje standardne opcije, kao i u tekstualnim editorima: Undo/Redo, 

Cut/Copy/Paste/Paste Special, Select All, Find and Replace/Find Next i mnoge druge. Jedna od 

interesantnih opcija je Tag Libraries... koja predstavlja biblioteku svih HTML tagova, ali i drugih 

tagova (XSLT, PHP, ASP, JSP,...). To je ono što ne postoji u običnim tekstualnim editorima, kao 

što je Notepad. Izborom taga a i atributa href, dobićemo objašnjenje kako da koristimo taj tag, 

kao što je prikazano na slici. 
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Meni View odnosi se na način prikazivanja prozora i panela u Dreamweaveru. Već je objašnjena 

razlika između Code/Design/Code and Design. Treba napomenuti još i prikaz Split Code, kojim 

možemo pratiti editovanje dve stranice u dva različita prozora istovremeno.  

Meni Insert odnosi se na dodavanje novih tagova na stranici ili div elemenata, slika ili drugih 

multimedijalnih elemenata (SWF flash animacija, apleta, video fajlova,...), ubacivanje tabela ili 

formi, hyperlink-ova, e-mail linkova ili anchor linkova, i mnoge druge opcije. 

Meni Format služi za sređivanje HTML ili CSS stilova, paragrafa, poravnanja, sređivanje listi, itd. 
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Kreiranje „template“ stranice - šablona 

Stvaranje template stranice, pomoći će nam da takvu stranicu, tzv. šablon, koristimo i u 
pravljenju drugih stranica. To će dati konzistentan izgled i olakšati upravljanje vašim sajtom 
(lakše je menjati samo šablonsku stranicu, nego u svim stranicama menjati izgled).  
 
U meniju izabrati File => New, i izabrati Blank Template => HTML Template => Layout <none> 
 

 
 
Potrebno je snimiti šablon opcijom File => Save. Dobićete poruku da šablon nema regione za 
ažuriranje (eng. editable regions), ali ćemo nastaviti sa snimanjem šablona, kome ćemo dati 
naziv template1. 
 

 
 
U Files panelu, pojaviće se direktorijum Templates, u kome će biti naš šablon template1.dwt. 
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Dizajniranje šablona 

Uobičajna struktura sajta je da se sastoji iz gornjeg zaglavlja (eng. header-a) sa navigacijom, dve 

kolone (jednom užom za sekundarnom navigacijom i jednom širom za sadržaj) i donjeg zaglavlja 

(eng. footer-a). Takav primer je dat na slici. 

 
 

Kada počinjemo dizajniranje, odabraćemo iz menija Insert => Layout Objects => Div Tag. 

 
 

Upišite u polju ID unikatan naziv  regiona npr. header. 
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Kliknite na dugme New CSS Rule da bi definisali novo pravilo u CSS fajlu. 

Prvo polje Selector Type predstavlja doseg našeg pravila. U polju Selector Name videćemo ID 

koji smo upisali, u ovom slučaju #header. 

 
 



Elektrotehnički fakultet Univerziteta u Beogradu 

 

11 

 

Iz padajućeg menija za Rule Definition odabraćemo New Style Sheet File kako bi napravili novi 

fajl sa stilovima.  

Fajl ćemo nazvati styles.css i snimiti ga. 

 

Ukoliko smo već jednom kreirali fajl sa stilovima, u padajućem meniju za Rule Definition 

videćemo ime fajla, pa je ubuduće potrebno izabrati tu stavku. Nakon što kliknemo OK otvoriće 

se prozor za rad sa stilovima koji će biti objašnjen dalje u dokumentu. 

Dodaćemo i ostale DIV-ove u šablon. Struktura DIV-ova koja je korišćena u primeru je data na 

slici. 

 
Header 

Meni 

Middle 

submenu content 

footer 
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Sledeća stvar koju je potrebno da uradimo je da definišemo editable regions tj. regione u kojima 

će se nalaziti naš sadržaj i koji mogu da se menjaju na svakoj strani nezavisno. 

Odaberite iz menija Insert => Template Objects => Editable Region. 

 

Otvoriće nam se prozor u kome je potrebno da damo ime regionu. Daćemo ime content. 
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U dizajn pregledu ovaj region biće označen kao na slici. Ako pogledamo kod videćemo ovaj 

region kao komentar. 

 

 

Snimićemo naš template i kreirati nove stranice na osnovu njega. 

Iz menija odabraćemo File => New =>Page from Template . 

 

Odaberemo sajt i temu koju želimo. 

Na stranici koju dobijemo sav sadržaj izvan content regiona ne možemo da menjamo, jer je 

samo content region editabilan. 

Promenićemo ime strane i upisati sadržaj. 
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Sačuvaćemo ovu stranicu kao index.html. Kreiraćemo i ostale strane po istom principu. 
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Dizajniranje CSS fajla 

Sa CSS fajlom možemo raditi na dva načina. Uz pomoć ugrađenih prozora ili direktnim pisanjem 
koda. Ukoliko pišemo kod ručno Dreamweaver će se potruditi da pogodi šta želimo i na osnovu 
toga da izbaci listu pravila. Takođe daće nam i pomoćne alate kao što je Color Picker za izbor 
boje. 
 
Kliknućemo na neki div i u Properties panelu kliknuti na Edit Rule. 
 

 
 

Otvoriće nam se nov prozor kao na slici ispod. 

 

CSS pravila su podeljena u kategorije koje se nalaze sa leve strane. Prva kategorija Type daje 

mogućnost podešavanja fonta. Neke od opcija su naziv fonta, veličina, debljina, dekoracija, boja 

i slično. 

Druga kategorija je Background i ona nam daje mogućnost podešavanja boje pozadine, 

pozadinske slike, ponavljanja pozadine i slično. 
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Treća kategorija je Block koja nam daje mogućnost podešavanja poravnjanja, razmaka između 

slova, identacije fonta i slično. 
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Četvrta kategorija je Box, koja nam daje mogućnost podešavanja visine i širine elementa, 

rastojanja od drugih elemenata (eng. Margins), rastojanja unutar elementa (eng. Padding), kao i 

stranu sa koje element treba da pluta. 

 

Peta kategorija je Border, koja nam daje mogućnost podešavanja okvira, boje širine itd. 

Šesta kategorija je List, koja nam daje mogućnost podešavanja tipa liste, slike umesto bullet-a, i 

mesto prikaza bullet-a. 

Sedma kategorija je Positioning, uz pomoć koje možemo da definišemo način prikaza elementa. 

Na primer: fiksiran, apsolutni, relativni, y-index, udaljenje od neke ivice i slično. 
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Nakon svih završenih podešavanja kliknemo OK. Ukoliko pogledamo kod u našem CSS fajlu 

videćemo da je Dreamweaver automatski generisao sva 

pravila za nas putem dijaloga. 

Joše jedan način za rad sa CSS-om je putem panela.   

Ukoliko ne vidite ovaj panel, uključite ga putem menija 

Window > CSS Styles. Imaćete hijerarhijski pregled 

pravila. Pravila možete menjati direktno kroz Properties 

tabelu ispod ili klikom na ikonicu olovke da otvorite 

dijalog. Nov stil možemo dodati klikom na ikonicu papira 

sa znakom plus. Stil možemo obrisati klikom na ikonicu 

kanta. 
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Rad sa slikama 

Da bismo ubacili sliku izabraćemo iz menija Insert => Image i izabrati našu sliku. 

  

U prozoru koji se pojavi upisaćemo alternativni tekst. Alternativni tekst je potrebno da pišemo, 

jer njega koriste čitači ekrana za osobe sa invaliditetom, tekstualni preglednici i pretraživači. 

Ovaj tekst treba da opisuje sliku. 

  

U dokumentu slika će biti u fokusu sa kvadratićima putem kojih možemo da menjamo veličinu 

slike i menjamo poziciju prevlačenjem preko stranice. 
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Opcije koje postoje za formatiranje slike biće vidljive u Properties panelu, kada je slika u fokusu. 

 

Ovde možemo podesiti širinu i visinu slike (W i H polje). Podrazumevani unos  je u pikselima,a 

ukoliko dodamo % biće u procentima. Možemo promeniti sliku klikom na ikonu foldera pored 

polja src ili direktnim upisom putanje. Sliku možemo da linkujemo tako da vodi do druge strane 

ili veće slike. To radimo klikom na ikonicu foldera pored polja Link i odabirom stranice/slike. 

Polje target označava gde će se taj link otvoriti (_blank je novi prozor). Slici možemo podesiti 

razmak od drugih elemenata i teksta (H i V space) kao i border (u pokselima). Poravnanje slike 

biramo iz padajućeg menija Align. 

Postoji i par naprednih alata za rad sa slikama:     

 

Prva ikonica označava mogućnost Sečenja slike (eng. Crop). 

Klikom na ovu ikonicu dobijamo fokus na slici (isti onaj koji 

se nalazi oko slike) kojim možemo da odredimo šta će biti 

vidljivo tj. Odsečeno. Tasterom Enter na tastaturi 

potvrđujemo promenu. 
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Treća ikonica sa leve strane nam daje mogućnost podešavanja kontrasta slike. 

 

Četvrta ikonica daje mogućnost promene oštrine slike. 

 

Napomena je da ovi alati daju bazičnu mogućnost rada sa slikama, a da je za napredan rad 

potreban alat kao što su Adobe Photoshop, Gimp itd. 

Slici možemo dodeliti ID (polje ID u properties), a onda kroz CSS da definišemo pravila (npr. 

border). Slici se može dodeliti i već postojeći CSS stil ukoliko je on definisan kao klasa putem 

padajućeg menija u properties panelu. 
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Kreiranje menija 

Sada ćemo se pozabaviti  delom koji je posvećen kreiranju menija. Da bismo ovo uradili, 
kreiraćemo div pod nazivom „meni“ sa odgovarajućim CSS pravilom. 
 
Prvo, treba da pozicioniramo kursor neposredno nakon „header“ div-a.  Ovo možemo uraditi na 
2 načina: 
 
1. Prvi način je u pogledu sa dizajnom (Design View) : 
 
Selektujte ’header’ div, tako što ćete kliknuti bilo gde u okviru ’header’ oblasti i odabradi 
’div#header’ tag koji se pojavljuje na dnu ekrana. 
 

 
 
Oblast za ’header’ tag će biti posebno istaknuta. Pritisnite ’desnu strelicu’ na svojoj tastaturi 
kako biste kursor pomerili odmah nakon ’header’ div-a. 
 
2. Drugi način je u pogledu sa kodom (Code View) : 
 
Kliknite na ’Code View’ dugme. 
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Nađite kod za ’header’ div i pozicionirajte kursor odmah iza taga za zatvaranje div-a, </div>. 

 
Kada ste pozicionirali kursor na pravo mesto, ubacite div pod imenom ’menu’. 
 
Odaberite Insert Layout Objects => Div Tag 
 
Zatim unesite: 
- ID: menu 
 
Pa kliknite na dugme ’New CSS Rule’ i unesite sledeće podatke: 
 
- Selector Type: ID 
- Selector Name: #menu 
- Rule Definition: styles.css 
 
i potvrdite sa OK. 
 
U ekranu za definiciju CSS pravila za ’#menu’ unesite sledeća svojstva: 
 
- Background => Background-image: images/menu-bg.jpg 
- Box => Width: 100% 
- Box => Height: 32px; 
 
Ponovo potvrdite sa OK, i idite na: Insert Div Tag screen => click OK. 
Videćete meni sa slikom u pozadini, širinom/visinom koje ste specificirali u fajlu template.dwt. 
Obrišite podrazumevani sadržaj koji je ubačen u ’menu’ div, i ubacite 4 sličice za meni - Home, 
About Us, Services, Contact Us. Meni je sada kompletan. Kasnije ćemo linkovati slike i 
kreiraćemo sve zahtevane html stranice. 
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Povezivanje stranica 

Sada treba da kreirate preostale 3 stranice i ulinkovati ih. Stranice about-us.html, services.html i 
contact-us.html  kreirajte na isti način kao što ste kreirali stranicu index.html. Ubacite 
odgovarajući sadržaj, slike, naslove i podnaslove za sve tri stranice. Svoje stranice ćete videti u 
panelu 'Files' [Window => Files]. 
 

 
 

Linkovanje stranica:  
 
Kada kliknemo na dugmad iz menija, želimo da odgovarajuća stranica bude prikazana. S 
obzirom na to da meni treba da se nalazi na svim stranicama, zadržali smo ovo u šablonu i kada 
ovde izvršimo ažuriranje (update), promene će biti vidljive na svim stranicama. 
 
Da biste linkovali stranice iz menija uradite sledeće: 
 
- Otvorite template fajl (template.dwt). Možete ga otvoriti iz ’Files’ panela - naćićete ga u 

’Templates’ folderu. 
- Linkujete ’Home’ dugme iz menija, odaberite ’Home’ sliku i linkujte je na index.html stranicu, u 

’Properties’ panelu.  
- Kliknite na ikonicu sa folderom odmah pored Link polja, i selektujte index.html. 
- U ’Border’ polje unesite vrednost 0. 
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- Slično uradite i za ostalu dugmad iz menija - About Us, Services i Contact Us. 
- Kada ste završili, sačuvajte šablon. 
- Dobićete dijalog koji će vas pitati da li želite da ažurirate šablonske (template) fajlove. Kliknite 

dugme ’Update’. 
 

 
 
- Sačuvajte i ostale stranice, u slučaju da su bile otvorene. 
- Sada kada pogledate stranice u svom pretraživaču, i kada kliknete na neko dugme iz menija,  

otvoriće se odgovarajuća strana. 
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Forme i validacija formi 

Sada je vreme da kreiramo formu za stranicu Contact Us. 
 
Da biste ovo uradili: 
 
- Otvorite contact-us.html 
- Idite na Insert => Form => Form 
- Na svojoj stranici ćete videti crveni okvir. Ovo je tag za formu, i sva polja forme se moraju     

nalaziti u njemu. 
- Insert Form => Text Field 
- U prozoru koji se otvori ukucajte ’Name’ u polju za labelu i kliknite na OK. 
 

 
 
- Slično, kreirajte polje za Email. 
- Takođe kreirajte i polje za poruku ’Message’. Tip ovog polja treba da bude ’text area’  
[Insert => Form => Text Area] 
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- Na kraju, kreirajte dugme [Insert => Form => Button] 
 

 
 
Na ovaj način ste kreirali HTML koji je neophodan za formu. Ipak, da bi preko ove forme bilo 
moguće poslati mejl, potrebna nam je neka serverska tehnologija PHP, ASP i slično. 
 
Međutim, moramo se pobrinuti i da korisnici u našu formu unesu ispravne podatke. Ovde će 
nam pomoći validacija forme. Forma koju ćemo da validiramo je prikazana na slici ispod: 
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Korak 1: Selektujte tag za formu 
Ovo možete uraditi tako što ćete kliknuti bilo gde na formu i selektovati <form> tag kada se 
pojavi na dnu prozora dokumenta. Forma će postati siva, i to znači da je selektovana. 
 

 
 
Korak 2: Otvorite ’Behavior Inspector’ 
Otvorite ’Behavior Inspector’ [Window => Behaviors] 
 

 
Korak 3: Dodajte validaciju forme 
Kliknite na ‘Add Behavior’ ikonicu (+ ikonica) i odaberite ’Validiraj Formu’. 
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Korak 4: Specificirajte zahteve za validaciju svakog od polja 
U ’Validate Form’ Panelu koji se bude otvorio, odaberite svako polje i specificirajte zahteve. 

 
Ispod možete videti primer validacionih zahteva: 
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name - Required, Anything  
 
email - Required, Email Address 
 
phone - Required, Number 
 

 
 
Korak 5: Kliknite OK, i isprobajte u pretraživaču 
Kliknite OK, kada završite sa podešavanjem validacije. 
 
Sačuvajte stranicu i pogledajte je u pretraživaču. Testirate formu tako što ćete unositi različite 
kombinacije dozvoljenih i nedozvoljenih vrednosti. Kada unesete neispravne vrednosti ili uopšte 
ne unesete vrednosti (kao na slici ispod), dobićete odgovarajuću poruku: 
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Tabele i rad sa tabelama 

Još jedan način dizajniranja šablona u Dreamweaver-u je koristeći tabele. Mi ćemo ovaj metod 
koristiti da napravimo oblast za podmeni u okviru šablona. 
 
- Otvorite template.dwt. 
- Obrišite ’Content for id ’’submenu’’ goes here’ iz ’submenu’ div-a. 
- Dok vam je kursor još u okviru ’submenu’ div-a ubacite tabelu [Insert => Table] sa 3 reda, 1 

kolonom, širinom od 201 piksela, graničnom linijom debljine 0, paddingom i spacing-om koji 
su 0 (Rows = 3, Columns = 1, Width = 201px, Border Tickness = 0, Cell Padding = 0 i Cell 
Spacing = 0) 

 

 
 
- Primetićete da se tabela pojavila u 'submenu' div-u. 
- Selektujte tabelu [desni klik negde na tabelu => Select Table] i uključite poravnanje po sredini  

[Align = Center] u 'Properties' panelu. 
- Kliknite na gornji red u tabeli i ubacite sliku 'submenu-top-bg.jpg'. 
- Kliknite na donji red u tabeli i ubacite sliku 'submenu-btm-bg.jpg'. 
 
Da postavite pozadinsku sliku na sredini: 
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- Kliknite na srednji red. 
- Iz 'Properties' panela, odaberite <New CSS Rule> and click ‘Edit Rule’ dugme. Kreirajte klasu 
pod nazivom ‘.sub-bg’ unutar CSS fajla ‘styles.css’. 
 

 
 
- U ‘CSS Rule Definition’ prozoru odaberite ‘submenu-bg.jpg’ kao sliku za pozadinu i odaberite 
‘repeat-y’ iz ‘Background-repeat’ opcija. 
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- Takođe, ne želimo da tekst podmenija bude prilepljen uz ivice srednjeg reda, pa ćemo mu 
dodeliti padding od 10 piksela unutar istog stila. Potvrdite sa OK. 
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Ukucajte stavke podmenija: 
 

 
- Možete kreirati nove stranice i kreirati linkove do njih iz oblasti za ovaj podmeni, a ovde 
možete staviti i tekstualni sadržaj koji će se pojavljivati na svim stranicama. 
 
- Sačuvajte šablon i ažurirajte sve stranice. 
 
- Pregledajte stranice u pretraživaču i testirajte sve linkove. 
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Dodatak 1: Horizontalni CSS meni  

Ovde  ćemo u kodu dati primer CSS padajućeg menija. Primeri rade na IE8+, FF 3.6+, Opera, 

Google Chrome. 

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" 

"http://www.w3.org/TR/html4/loose.dtd"> 

<HTML> 

 <HEAD> 

  

  <style> 

/* ovim skidamo bullete ispred liste i rastojanja*/ 

ul.dropdown, ul.dropdown li, ul.dropdown ul { 

 list-style: none; 

 margin: 0; 

 padding: 0; 

 background-color: #eee; 

color: #000; 

} 

/* generalna podesavanja*/ 

ul.dropdown { 

 position: relative; 

 z-index: 998; 

 float: left; 

 font-weight: bold; 

} 

/* definisemo visinu i mesto pojavljivanja elemenata liste,kao i boju*/ 

ul.dropdown li { 

 float: left; 

 line-height: 20px;/* visina reda,odnosno menija*/ 

 vertical-align: middle; 

 zoom:1; /*nestandardno ali potrebno za IE */  

 padding: 7px 10px; /* top right */ 

 border-style: solid; 

 border-width: 1px 1px 1px 0; 

 border-color: #fff #d9d9d9 #d9d9d9; 

 background-color: #f6f6f6; 

 color: #000; 

} 

/* kada predjemo misem preko */ 

ul.dropdown li.hover, ul.dropdown li:hover { 

 position: relative; 

 z-index: 999; 

 cursor: default; 

} 

/*za listu unutar liste, odnosno padajucu listu,na pocetku srkivena */ 
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ul.dropdown ul { 

 visibility: hidden; 

 position: absolute; 

 top: 100%; 

 left: 0; 

 z-index: 999; 

 width: 150px; 

 margin-top: 1px; 

} 

ul.dropdown ul li { 

 float: none; 

  font-weight: normal; 

} 

/* prikazemo podlistu tek sto predjemo misem preko*/ 

ul.dropdown li:hover > ul { 

 visibility: visible; 

} 

/* boje za linkove */ 

ul.dropdown a:link, 

ul.dropdown a:visited { color: #000; text-decoration: none; } 

ul.dropdown a:hover { color: #000; } 

ul.dropdown a:active { color: #ffa500; } 

</style> 

 </HEAD> 

 <BODY> 

 <ul class="dropdown"> 

 <li><a href="./">Pocetna</a></li> 

 <li>Proizvodi 

  <ul> 

   <li><a href="./">Proizvod 1</a></li> 

   <li><a href="./">Proizvod 2</a></li> 

   <li><a href="./">Proizvod 3</a></li> 

   <li><a href="./">Proizvod 4</a></li> 

   <li><a href="./">Proizvod 5</a></li> 

 

  </ul> 

 </li> 

 <li>Usluge 

  <ul> 

   <li><a href="./">Usluga 1</a></li> 

   <li><a href="./">Usluga 2</a></li> 

   <li><a href="./">Usluga 3</a></li> 

   <li><a href="./">Usluga 4</a></li> 

   <li><a href="./">Usluga 5</a></li> 

  </ul> 

 </li> 

 <li>Galerija 
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  <ul> 

   <li><a href="./">Galerija 1</a></li> 

   <li><a href="./">Galerija 2</a></li> 

   <li><a href="./">Galerija 3</a></li> 

   <li><a href="./">Galerija 4</a></li> 

   <li><a href="./">Galerija 5</a></li> 

  </ul> 

 </li> 

 

 <li><a href="./">Kontakt</a></li> 

</ul> 

   

 </BODY> 

</HTML> 
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Dodatak 2: Vertikalni CSS meni  

Ovde  ćemo u kodu dati primer CSS padajućeg menija. Primeri rade na IE8+, Firefox 3.6+, Opera, 

Google Chrome. 

Pitanje: Pronađite razliku u primeru horizintalnog i vertikalnog menija! 

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" 

"http://www.w3.org/TR/html4/loose.dtd"> 

<HTML> 

 <HEAD> 

  

  <style> 

/* ovim skidamo bullete ispred liste i rastojanja*/ 

ul.dropdown, ul.dropdown li, ul.dropdown ul { 

 list-style: none; 

 margin: 0; 

 padding: 0; 

 background-color: #eee; 

color: #000; 

} 

 

/* generalna podesavanja*/ 

ul.dropdown { 

 position: relative; 

 z-index: 998; 

 float: left; 

 font-weight: bold; 

  width: 200px;/* ogranicimo sirinu */ 

} 

 

/* definisemo visinu i mesto pojavljivanja elemenata liste,kao i boju*/ 

ul.dropdown li { 

 float: none; 

 line-height: 20px;/* visina reda,odnosno menija*/ 

 vertical-align: middle; 

 zoom:1; /*nestandardno ali potrebno za IE */  

 padding: 7px 10px; /* top right */ 

 border-style: solid; 

 border-width: 1px 1px 1px 0; 

 border-color: #fff #d9d9d9 #d9d9d9; 

 background-color: #f6f6f6; 

 color: #000; 

} 

 

/* kada predjemo misem preko */ 
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ul.dropdown li.hover, ul.dropdown li:hover { 

 position: relative; 

 z-index: 999; 

 cursor: default; 

} 

 

/*za listu unutar liste, odnosno padajucu listu,na pocetku srkivena */ 

ul.dropdown ul { 

 visibility: hidden; 

 position: absolute; 

 

 z-index: 999; 

 width: 150px; 

 margin-top: 1px; 

 top: 1px; 

 left: 99%; 

} 

 

ul.dropdown ul li { 

 float: none; 

  font-weight: normal; 

} 

 

 

/* prikayemo podlistu tek sto predjemo misem preko*/ 

ul.dropdown li:hover > ul { 

 visibility: visible; 

} 

 

/* boje za linkove */ 

 

ul.dropdown a:link, 

ul.dropdown a:visited { color: #000; text-decoration: none; } 

ul.dropdown a:hover  { color: #000; } 

ul.dropdown a:active { color: #ffa500; } 

 

  </style> 

 </HEAD> 

 

 <BODY> 

 <ul class="dropdown"> 

 <li><a href="./">Pocetna</a></li> 

 <li>Proizvodi 

  <ul> 

   <li><a href="./">Proizvod 1</a></li> 

   <li><a href="./">Proizvod 2</a></li> 

   <li><a href="./">Proizvod 3</a></li> 
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   <li><a href="./">Proizvod 4</a></li> 

   <li><a href="./">Proizvod 5</a></li> 

 

  </ul> 

 </li> 

 <li>Usluge 

  <ul> 

   <li><a href="./">Usluga 1</a></li> 

   <li><a href="./">Usluga 2</a></li> 

   <li><a href="./">Usluga 3</a></li> 

   <li><a href="./">Usluga 4</a></li> 

   <li><a href="./">Usluga 5</a></li> 

  </ul> 

 </li> 

 <li>Galerija 

  <ul> 

   <li><a href="./">Galerija 1</a></li> 

   <li><a href="./">Galerija 2</a></li> 

   <li><a href="./">Galerija 3</a></li> 

   <li><a href="./">Galerija 4</a></li> 

   <li><a href="./">Galerija 5</a></li> 

  </ul> 

 </li> 

 

 <li><a href="./">Kontakt</a></li> 

</ul> 

   

 </BODY> 

</HTML> 
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Dodatak 3: Image Slider  

Ovde ćemo prikazati slajder za slike, a samim tim biće ukratko objašnjen i rad sa JavaScript-om 

iz Dreamweaver-a. 

Na početku je naravno potrebno kreirati novu HTML stranicu. Zatim, potrebno je u folder gde 

nam se nalazi projekat da prekopiramo sve slike koje će nam biti potrebne: u ovom slučaju, 

left.png i right.png (koje predstavljaju strelice na čiji klik će se menjati slike) i img0.jpg, img1.jpg, 

img2.jpg. 

Nakon toga u našu stranicu možemo da ubacimo slike left.png, img0.jpg i right.png, tako da 

dobijemo raspored kao na slici ispod. Za ubacivanje koristimo opciju Insert -> Image.  

 

Kada ubacimo sve slike, onda im treba dati odgovarajući ID što možemo uraditi desnim klikom 

na sliku i odabirom opcije ID. Slikama ćemo dodeliti sledeće ID-jeve: 

left.png -> left 

img0.jpg -> image 

right.png -> right 

Sada ćemo uključiti Behaviours prozor, tako što ćemo odabrati Window -> Behaviours. 

Primećujemo da nam se sa desne strane pojavio Behaviours prozor, kao na slici. 
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Treba odabrati sliku left.png, u prozoru za Behaviors kliknuti na veliko dugme ‘plus’ i odabrati 

‘Call JavaScript’. Za naziv funkcije koju treba pozvati, ukucaćemo ‘moveLeft()’. 

Zatim, za dugme koje nam služi za pomeranje u desno uradićemo isto to, samo što ćemo za 

funkciju upisati ’moveRight()’. 

 

Sada, u prozoru za kod, treba dodati sledeće, neposredno ispred tag-a </script>. 

 

   var i = 0; //trenutno prikazana slika 

   var n = 3; //ukupan broj slika 

    

   var images = new Array(); 

   images[0] = "img0.jpg"; 

   images[1] = "img1.jpg"; 

   images[2] = "img2.jpg"; 

 

   function moveLeft(){ 

    i--; 

    if(i<0) i=0; 

     

    document.getElementById('image').src = images[i]; 

   } 
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   function moveRight(){ 

    i++; 

    if(i>=n) i=n; 

     

    document.getElementById('image').src = images[i]; 

   } 

 

 

 

Nakon ovoga, naš slider je završen i možemo ga testirati. 
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NAPOMENA: 

 

Ako pogledamo JavaScript kod, možemo uočiti sledeće: 

 

i – promenljiva koja predstavlja redni broj slike koja je trenutno prikazana 

n – ukupan broj slika, kako bi se znalo kada smo došli do poslednje slike 

images[] – niz koji sadrži adrese svih slika 

 

U nastavku je dat i celokupan kod: 

 
<html> 

 <head> 

  <script type="text/javascript"> 

   var i = 0; //trenutno prikazana slika 

   var n = 3; //ukupan broj slika  

   var images = new Array(); 

   images[0] = "img0.jpg"; 

   images[1] = "img1.jpg"; 

   images[2] = "img2.jpg"; 

  

   function moveLeft(){ 

    i--; 

    if(i<0) i=0; 

    document.getElementById('image').src = images[i]; 

   } 

 

   function moveRight(){ 

    i++; 

    if(i>=n) i=n;     

    document.getElementById('image').src = images[i]; 

   } 

  </script> 

 </head> 

 <body> 

  <img src="left.png" id="left" onClick="moveLeft()" /> 

  <img src="img0.jpg" id="image" /> 

  <img src="right.png" id="right" onClick="moveRight()" /> 

 </body> 

</html> 


